If your ISP giving one PPPoE Account that have multiple IP Address such as /30
/29
You can do NAT Routing
Let say your ISP assign you /29
PPPoE IP Address, then add your address into IP ➡ Address
- 24.10.20.101
- 24.10.20.102
- 24.10.20.103
- 24.10.20.104
- 24.10.20.105
- 24.10.20.106
Then you need do NAT Rules and Arrangement like this:
# 1:1 NAT for Web Server
/ip firewall nat add chain=srcnat src-address=192.168.1.2 out-interface=pppoe-out1 action=src-nat to-addresses=24.10.20.106
/ip firewall nat add chain=dstnat dst-address=24.10.20.106 in-interface=pppoe-out1 action=dst-nat to-addresses=192.168.1.2
# 1:1 NAT for Mail Server
/ip firewall nat add chain=srcnat src-address=192.168.1.3 out-interface=pppoe-out1 action=src-nat to-addresses=24.10.20.105
/ip firewall nat add chain=dstnat dst-address=24.10.20.105 in-interface=pppoe-out1 action=dst-nat to-addresses=192.168.1.3
# 1:1 NAT for Proxmox VE
/ip firewall nat add chain=srcnat src-address=192.168.1.4 out-interface=pppoe-out1 action=src-nat to-addresses=24.10.20.104
/ip firewall nat add chain=dstnat dst-address=24.10.20.104 in-interface=pppoe-out1 action=dst-nat to-addresses=192.168.1.4
# 1:1 NAT for HAProxy
/ip firewall nat add chain=srcnat src-address=192.168.1.5 out-interface=pppoe-out1 action=src-nat to-addresses=24.10.20.103
/ip firewall nat add chain=dstnat dst-address=24.10.20.103 in-interface=pppoe-out1 action=dst-nat to-addresses=192.168.1.5
# masquerade
...
Take note that Masquerade (default gateway) must be below 1:1 NAT rules